using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<desired_password>)";
string substitution = @"stuff";
string input = @"bilbo <desired_password> <desired_password>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}