#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(<desired_password>)"
Local $sString = "bilbo <desired_password> <desired_password>"
Local $sSubst = "stuff"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)