# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:[^\\]{{)\s*RIO_PLAYER_NAME\s*}}/ Richard/gm;t' <<< "Welcome{{ RIO_PLAYER_NAME}} to the event!
Welcome {{ RIO_PLAYER_NAME}} to the event!
Welcome \\{{RIO_PLAYER_NAME}} to the event!
Welcome\\{{RIO_PLAYER_NAME}} to the event!"