#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:[^\\]{{)\s*RIO_PLAYER_NAME\s*}}"
Local $sString = "Welcome{{ RIO_PLAYER_NAME}} to the event!" & @CRLF & _
"" & @CRLF & _
"Welcome {{ RIO_PLAYER_NAME}} to the event!" & @CRLF & _
"" & @CRLF & _
"Welcome \\{{RIO_PLAYER_NAME}} to the event!" & @CRLF & _
"" & @CRLF & _
"Welcome\\{{RIO_PLAYER_NAME}} to the event!"
Local $sSubst = " Richard"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)