import Foundation
let pattern = #"(?:[^\\]{{)\s*RIO_PLAYER_NAME\s*}}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Welcome{{ RIO_PLAYER_NAME}} to the event!
Welcome {{ RIO_PLAYER_NAME}} to the event!
Welcome \\{{RIO_PLAYER_NAME}} to the event!
Welcome\\{{RIO_PLAYER_NAME}} to the event!
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" Richard"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)