package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:[^\\]{{)\s*RIO_PLAYER_NAME\s*}}`)
var str = `Welcome{{ RIO_PLAYER_NAME}} to the event!
Welcome {{ RIO_PLAYER_NAME}} to the event!
Welcome \\{{RIO_PLAYER_NAME}} to the event!
Welcome\\{{RIO_PLAYER_NAME}} to the event!`
var substitution = " Richard"
fmt.Println(re.ReplaceAllString(str, substitution))
}