using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[^\\]{{)\s*RIO_PLAYER_NAME\s*}}";
string substitution = @" Richard";
string input = @"Welcome{{ RIO_PLAYER_NAME}} to the event!
Welcome {{ RIO_PLAYER_NAME}} to the event!
Welcome \\{{RIO_PLAYER_NAME}} to the event!
Welcome\\{{RIO_PLAYER_NAME}} to the event!";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}