$re = '/(?:[^\\\\]{{)\s*RIO_PLAYER_NAME\s*}}/m';
$str = 'Welcome{{ RIO_PLAYER_NAME}} to the event!
Welcome {{ RIO_PLAYER_NAME}} to the event!
Welcome \\\\{{RIO_PLAYER_NAME}} to the event!
Welcome\\\\{{RIO_PLAYER_NAME}} to the event!';
$subst = " Richard";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;