import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[^\\\\]\\{\\{)\\s*RIO_PLAYER_NAME\\s*\\}\\}";
final String string = "Welcome{{ RIO_PLAYER_NAME}} to the event!\n\n"
+ "Welcome {{ RIO_PLAYER_NAME}} to the event!\n\n"
+ "Welcome \\\\{{RIO_PLAYER_NAME}} to the event!\n\n"
+ "Welcome\\\\{{RIO_PLAYER_NAME}} to the event!";
final String subst = " Richard";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}