const regex = /(?:[^\\]{{)\s*RIO_PLAYER_NAME\s*}}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[^\\\\]{{)\\s*RIO_PLAYER_NAME\\s*}}', 'gm')
const str = `Welcome{{ RIO_PLAYER_NAME}} to the event!
Welcome {{ RIO_PLAYER_NAME}} to the event!
Welcome \\\\{{RIO_PLAYER_NAME}} to the event!
Welcome\\\\{{RIO_PLAYER_NAME}} to the event!`;
const subst = ` Richard`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);