re = /(?:[^\\]{{)\s*RIO_PLAYER_NAME\s*}}/m
str = 'Welcome{{ RIO_PLAYER_NAME}} to the event!
Welcome {{ RIO_PLAYER_NAME}} to the event!
Welcome \\\\{{RIO_PLAYER_NAME}} to the event!
Welcome\\\\{{RIO_PLAYER_NAME}} to the event!'
subst = ' Richard'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result