# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[?&]page=[^&\n]+$|([&?])page=[^&\n]+&/$1/gm;t' <<< "url1?name=John&page=12&mfgid=310
url2?name=John&page=12
url3?page=12&name=John&mfgid=320&my-page=12&foo=bar
url4?page=12
"