$re = '/[?&]page=[^&\n]+$|([&?])page=[^&\n]+&/m';
$str = 'url1?name=John&page=12&mfgid=310
url2?name=John&page=12
url3?page=12&name=John&mfgid=320&my-page=12&foo=bar
url4?page=12
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;