import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[?&]page=[^&\\n]+$|([&?])page=[^&\\n]+&";
final String string = "url1?name=John&page=12&mfgid=310\n"
+ "url2?name=John&page=12\n"
+ "url3?page=12&name=John&mfgid=320&my-page=12&foo=bar\n"
+ "url4?page=12\n";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}