use strict;
my $str = 'url1?name=John&page=12&mfgid=310
url2?name=John&page=12
url3?page=12&name=John&mfgid=320&my-page=12&foo=bar
url4?page=12
';
my $regex = qr/[?&]page=[^&\n]+$|([&?])page=[^&\n]+&/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";