package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[?&]page=[^&\n]+$|([&?])page=[^&\n]+&`)
var str = `url1?name=John&page=12&mfgid=310
url2?name=John&page=12
url3?page=12&name=John&mfgid=320&my-page=12&foo=bar
url4?page=12
`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}