#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[?&]page=[^&\n]+$|([&?])page=[^&\n]+&"
Local $sString = "url1?name=John&page=12&mfgid=310" & @CRLF & _
"url2?name=John&page=12" & @CRLF & _
"url3?page=12&name=John&mfgid=320&my-page=12&foo=bar" & @CRLF & _
"url4?page=12" & @CRLF & _
""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)