# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[?&]page=[^&\n]+$|([&?])page=[^&\n]+&"
test_str = ("url1?name=John&page=12&mfgid=310\n"
"url2?name=John&page=12\n"
"url3?page=12&name=John&mfgid=320&my-page=12&foo=bar\n"
"url4?page=12\n")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.