# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[\[([A-Z][\S\s]+?)\]\]/## $1\r\n/gm;t' <<< "
[[Az akkád shadu, asszír-babiloni sadu = hegy szavai sátáni összefüggéséről
]]"