import Foundation
let pattern = #"\[\[([A-Z][\S\s]+?)\]\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[[Az akkád shadu, asszír-babiloni sadu = hegy szavai sátáni összefüggéséről
]]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ###"## $1\r\n"###
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)