// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[\[([A-Z][\S\s]+?)\]\]").unwrap();
let string = "
[[Az akkád shadu, asszír-babiloni sadu = hegy szavai sátáni összefüggéséről
]]";
let substitution = "## $1\\r\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}