using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\[([A-Z][\S\s]+?)\]\]";
string substitution = @"## $1\r\n";
string input = @"
[[Az akkád shadu, asszír-babiloni sadu = hegy szavai sátáni összefüggéséről
]]";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}