package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[\[([A-Z][\S\s]+?)\]\]`)
var str = `
[[Az akkád shadu, asszír-babiloni sadu = hegy szavai sátáni összefüggéséről
]]`
var substitution = "## $1\r\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}