import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[\\[([A-Z][\\S\\s]+?)\\]\\]";
final String string = "\n"
+ "[[Az akkád shadu, asszír-babiloni sadu = hegy szavai sátáni összefüggéséről\n"
+ "]]";
final String subst = "## $1\\r\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}