use strict;
my $str = '
[[Az akkád shadu, asszír-babiloni sadu = hegy szavai sátáni összefüggéséről
]]';
my $regex = qr/\[\[([A-Z][\S\s]+?)\]\]/mp;
my $subst = '## $1\\r\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";