re = /\[\[([A-Z][\S\s]+?)\]\]/m
str = '
[[Az akkád shadu, asszír-babiloni sadu = hegy szavai sátáni összefüggéséről
]]'
subst = '## $1\\r\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result