# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*?chr(.*?)\.recalibrated.*/\1/g;t' <<< "output.chr10.recalibrated
output.chr11.recalibrated
output.chrY.recalibrated"