using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*?chr(.*?)\.recalibrated.*";
string substitution = @"\1";
string input = @"output.chr10.recalibrated
output.chr11.recalibrated
output.chrY.recalibrated";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}