#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ".*?chr(.*?)\.recalibrated.*"
Local $sString = "output.chr10.recalibrated" & @CRLF & _
"output.chr11.recalibrated" & @CRLF & _
"output.chrY.recalibrated"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)