use strict;
my $str = 'output.chr10.recalibrated
output.chr11.recalibrated
output.chrY.recalibrated';
my $regex = qr/.*?chr(.*?)\.recalibrated.*/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";