$re = '/.*?chr(.*?)\.recalibrated.*/';
$str = 'output.chr10.recalibrated
output.chr11.recalibrated
output.chrY.recalibrated';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;