import Foundation
let pattern = #".*?chr(.*?)\.recalibrated.*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
output.chr10.recalibrated
output.chr11.recalibrated
output.chrY.recalibrated
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)