re = /.*?chr(.*?)\.recalibrated.*/
str = 'output.chr10.recalibrated
output.chr11.recalibrated
output.chrY.recalibrated'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result