const regex = /.*?chr(.*?)\.recalibrated.*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*?chr(.*?)\\.recalibrated.*', 'g')
const str = `output.chr10.recalibrated
output.chr11.recalibrated
output.chrY.recalibrated`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);