using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S)#([0-9a-zA-Z]+)";
string substitution = @"<a href=""/hashtag/$1"">#$1</a>";
string input = @"#ত্বকের উজ্জ্বলতা কী?
#কীভাবে ধরে রাখবেন উজ্জ্বলতা?
#PRP (Vampire Facial) #Chemical Peel #Oxyfacial #Hydrafacial #Glutathione Injection";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}