import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\S)#([0-9a-zA-Z]+)";
final String string = "#ত্বকের উজ্জ্বলতা কী?\n\n"
+ "#কীভাবে ধরে রাখবেন উজ্জ্বলতা?\n\n"
+ "#PRP (Vampire Facial) #Chemical Peel #Oxyfacial #Hydrafacial #Glutathione Injection";
final String subst = "<a href=\"/hashtag/$1\">#$1</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}