re = /(?<!\S)#([0-9a-zA-Z]+)/i
str = '#ত্বকের উজ্জ্বলতা কী?
#কীভাবে ধরে রাখবেন উজ্জ্বলতা?
#PRP (Vampire Facial) #Chemical Peel #Oxyfacial #Hydrafacial #Glutathione Injection'
subst = '<a href="/hashtag/$1">#$1</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result