const regex = /(?<!\S)#([0-9a-zA-Z]+)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\S)#([0-9a-zA-Z]+)', 'gi')
const str = `#ত্বকের উজ্জ্বলতা কী?
#কীভাবে ধরে রাখবেন উজ্জ্বলতা?
#PRP (Vampire Facial) #Chemical Peel #Oxyfacial #Hydrafacial #Glutathione Injection`;
const subst = `<a href="/hashtag/$1">#$1</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);