# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!\S)#([0-9a-zA-Z]+)"
test_str = ("#ত্বকের উজ্জ্বলতা কী?\n\n"
"#কীভাবে ধরে রাখবেন উজ্জ্বলতা?\n\n"
"#PRP (Vampire Facial) #Chemical Peel #Oxyfacial #Hydrafacial #Glutathione Injection")
subst = "<a href=\"/hashtag/$1\">#$1</a>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.