use strict;
my $str = '#ত্বকের উজ্জ্বলতা কী?
#কীভাবে ধরে রাখবেন উজ্জ্বলতা?
#PRP (Vampire Facial) #Chemical Peel #Oxyfacial #Hydrafacial #Glutathione Injection';
my $regex = qr/(?<!\S)#([0-9a-zA-Z]+)/ip;
my $subst = '<a href="/hashtag/$1">#$1</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";