#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?si)^\d\d\/\d\d\/\d\d\d\d\s" & @CRLF & _
""
Local $sString = "15/09/2018 15/09/2018" & @CRLF & _
"3,000.00 8,23,202.12" & @CRLF & _
"5294707265" & @CRLF & _
"Principa -" & @CRLF & _
"NACH-DR-BD-" & @CRLF & _
"15/09/2018 15/09/2018"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")