import re
regex = re.compile((r"^\d\d\/\d\d\/\d\d\d\d\s\n"), flags=re.DOTALL | re.IGNORECASE)
test_str = ("15/09/2018 15/09/2018\n"
"3,000.00 8,23,202.12\n"
"5294707265\n"
"Principa -\n"
"NACH-DR-BD-\n"
"15/09/2018 15/09/2018")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")