package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?si)^\d\d\/\d\d\/\d\d\d\d\s
`)
var str = `15/09/2018 15/09/2018
3,000.00 8,23,202.12
5294707265
Principa -
NACH-DR-BD-
15/09/2018 15/09/2018`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}