// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?si)^\d\d\/\d\d\/\d\d\d\d\s
").unwrap();
let string = "15/09/2018 15/09/2018
3,000.00 8,23,202.12
5294707265
Principa -
NACH-DR-BD-
15/09/2018 15/09/2018";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}