const regex = new RegExp('^\\d\\d\\/\\d\\d\\/\\d\\d\\d\\d\\s
', 'gsi')
const str = `15/09/2018 15/09/2018
3,000.00 8,23,202.12
5294707265
Principa -
NACH-DR-BD-
15/09/2018 15/09/2018`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}