import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d\\d\\/\\d\\d\\/\\d\\d\\d\\d\\s\n";
final String string = "15/09/2018 15/09/2018\n"
+ "3,000.00 8,23,202.12\n"
+ "5294707265\n"
+ "Principa -\n"
+ "NACH-DR-BD-\n"
+ "15/09/2018 15/09/2018";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}