#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^[a-zA-Z]:(\\\\[^\\ ]+)*"
Local $sString = "C:\\dd\\sd\\faf.txt true" & @CRLF & _
"c:\\ss\\dw\\fbf.txt true" & @CRLF & _
"D:\\ff\\d3\\fcf.txt true" & @CRLF & _
"d:\\da\\ds\\Df\\ff.txt true" & @CRLF & _
"2:\\ad\\dd\\ff false" & @CRLF & _
"2:\ad\\dd\\ff false" & @CRLF & _
"d:\da\\ds\\Df\\ff.txt false" & @CRLF & _
"c\\ss\\dw\\fbf.txt false" & @CRLF & _
"D:\da\\ds\\Df\\ff.txt false" & @CRLF & _
"D:\\da\\ds\Df\\ff.txt false"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")