// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^[a-zA-Z]:(\\\\[^\\ ]+)*").unwrap();
let string = "C:\\\\dd\\\\sd\\\\faf.txt true
c:\\\\ss\\\\dw\\\\fbf.txt true
D:\\\\ff\\\\d3\\\\fcf.txt true
d:\\\\da\\\\ds\\\\Df\\\\ff.txt true
2:\\\\ad\\\\dd\\\\ff false
2:\\ad\\\\dd\\\\ff false
d:\\da\\\\ds\\\\Df\\\\ff.txt false
c\\\\ss\\\\dw\\\\fbf.txt false
D:\\da\\\\ds\\\\Df\\\\ff.txt false
D:\\\\da\\\\ds\\Df\\\\ff.txt false";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}