import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z]:(\\\\\\\\[^\\\\ ]+)*";
final String string = "C:\\\\dd\\\\sd\\\\faf.txt true\n"
+ "c:\\\\ss\\\\dw\\\\fbf.txt true\n"
+ "D:\\\\ff\\\\d3\\\\fcf.txt true\n"
+ "d:\\\\da\\\\ds\\\\Df\\\\ff.txt true\n"
+ "2:\\\\ad\\\\dd\\\\ff false\n"
+ "2:\\ad\\\\dd\\\\ff false\n"
+ "d:\\da\\\\ds\\\\Df\\\\ff.txt false\n"
+ "c\\\\ss\\\\dw\\\\fbf.txt false\n"
+ "D:\\da\\\\ds\\\\Df\\\\ff.txt false\n"
+ "D:\\\\da\\\\ds\\Df\\\\ff.txt false";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}