use strict;
my $str = 'C:\\\\dd\\\\sd\\\\faf.txt true
c:\\\\ss\\\\dw\\\\fbf.txt true
D:\\\\ff\\\\d3\\\\fcf.txt true
d:\\\\da\\\\ds\\\\Df\\\\ff.txt true
2:\\\\ad\\\\dd\\\\ff false
2:\\ad\\\\dd\\\\ff false
d:\\da\\\\ds\\\\Df\\\\ff.txt false
c\\\\ss\\\\dw\\\\fbf.txt false
D:\\da\\\\ds\\\\Df\\\\ff.txt false
D:\\\\da\\\\ds\\Df\\\\ff.txt false';
my $regex = qr/^[a-zA-Z]:(\\\\[^\\ ]+)*/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}